
Chapter 6 - Modify
Ease of modification is a critical factor when modeling lighting systems. This is partly due to the complexity of the overall architectural design process (project phases and revisions for example)
and the fact that lighting design is largely a matter of iterative process and analysis. The initially constructed model and the final design are rarely one and the same.

The Modify tab of the Ribbonbar contains
commands to alter the current model.

 

This chapter will introduce the concepts and commands used in Visual to permit modification of lighting designs. Discussion of the Copy, Extrude, Pull, Array Polar, Array Rectangular,
Mirror, and Offset are commands can be found in  Constructing by Reference.
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6.1 Array Polar
The Array Polar command applies to all object types and is used to create multiple copies of all selected objects in columns (x-direction), rows (y-direction), and/or levels (z-direction). The most
common use of the Array Polar command is with Solid Objects since they are most often placed in such Arrays to models circular, spherical, and cylindrical objects.

The Array Polar command can be found on the Modify tab of the Ribbonbar.  

To Array Polar objects, left-click the object(s) to be used as the basis for the Array
with the selection box or use a selection window to select a set of objects. Right-click
to complete the selection process of base objects.

See Selecting Objects for information on object selection methods.

 

Spacing information for Arrayed objects must be provided in the Properties tab.
Angular Separation spaces newly created objects at the angle specified and
creates a total quantity (including the original object) also as specified. Positive angles
yield clockwise arrays; negative angles yields counterclockwise arrays. See below for
information on Angular Extent.

 

Specify a Base Point with the mouse, keyboard, or Object Snap.  

After selecting the Base Point for the Array, Visual automatically completes the
command.

At right, 24 objects are arrayed in a polar fashion 15° apart as is shown in
the Properties tab input boxes above.

 

Angular Extent allows the user to define how many objects are created (including
the original object) and then specify the total angular extent to fill with objects. The
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process is the same as before: select objects, specify a Base Point, and Visual
automatically completes the command.

Two examples that create a full faceted circle (polygon) are warranted to illustrate the difference between the angular options. Once the radial lines are arrayed, the faceted circle is drawn
with the Polyline command:

Angular Extent option: an angle of 360 is specified, and the number of objects to
use to fill that angle is chosen. A quantity of 24 yields 15° wedges that might be the
base of the hemisphere shown above, 6 yields a hexagon, and 8 yields an octagon.

 

Angular Separation option : the inputs left to right in the examples are 15° angle
and quantity of 24. 60° angle and quantity of 6, or 45° of angle and quantity of 8. At far
right, 15° and quantity of 7 yields 90° of arc.

[Angular Separation] X [Quantity] = [Angular Extent] e.g. 15 X 24 = 360 as above.

 

Like many commands, Array Polar can be used on Luminaires, Background Objects, Solid Objects, and Calculation Zones.
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6.2 Array Rectangular
The Array Rectangular command applies to all object types and is used to create multiple copies of all selected objects in columns (x-direction), rows (y-direction), and/or levels (z-direction).
The most common use of the Array Rectangular command is with Luminaire Objects since they are most often placed in such Arrays in reality.

The Array Rectangular command can be found on the Modify tab and the Home
tab of the Ribbonbar.

 

To Array Rectangular objects, left-click the object(s) to be used as the basis for the
Array with the selection box or use a selection window to select a set of objects.
Right-click to complete the selection process of base objects.

See Selecting Objects for information on object selection methods.

 

Spacing information for Arrayed objects must be provided in the Properties tab.
Array By Spacing spaces newly created objects at the distance specified. The
limits of the Array are specified with the mouse; defined by the Base Point and
Destination Point. See below for information on Array By Quantity.

 

Specify a Base Point with the mouse, keyboard, or Object Snap.  

After selection of a Base Point, movement of the mouse crosshairs within the
Design Environment will display a graphical representation of the selected objects
as they will be arrayed with the specified spacing to aid in the proper selection of a
Destination Point.

In the example at right, Luminaire Objects are pre-spaced at 6ft in the x-direction
and 4ft in the y-direction. The crosshairs indicate the current extent of the Array.
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Select a Destination Point with the mouse, keyboard, or Object Snap.  

After selecting the Destination Point, Visual automatically completes the command.  

Array By Quantity allows the user to define how many objects are created and then
specify the X, Y, and/or Z-spacing with the mouse, keyboard or Object Snap.

 

As before, moving the mouse in the Array By Quantity mode illustrates how the
columns and rows would be placed if the mouse was clicked in that location with the
quantity fixed and the spacing variable with mouse movement.

For example, at right, the mouse has been moved 2x2 and the 6 columns and 2 rows
are shown more compact than is likely desired.

 

Select a Destination Point that defines the X, Y, and/or Z-spacing with the mouse,
keyboard or Object Snap. For example, specifying a quantity of X=6 and Y=2 and
then using the mouse to specify Base Point and Destination Point 6x4 apart
yields the same Array as was shown above.

 

Like many commands, Array Rectangular can be used on Luminaires, Background Objects, Solid Objects, and Calculation Zones.
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6.3 Convert To Background
Solid Objects can be converted to Background Objects.

The Convert To Background command can be found on the Modify tab of the
Ribbonbar.

 

To Convert To Background, select the Solid Object to be converted by left-
clicking the object or using a window selection method.

 

Right-click the mouse or press Enter to end the command and make the conversion.
The new Background Object(s) will reside on the same Layer as the original
Solid Object(s).

 

Grouped Solid Objects (Rooms, Structures, etc) can be converted in bulk by
clicking the Group. Individual Polygons will be created since there is not an analog
to "group" Background Objects.

 

See Convert To Solid for the opposite functionality.
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6.4 Convert To Solid
Background Objects can be converted to Solid Objects.

The Convert To Solid command can be found on the Modify tab of the
Ribbonbar.

 

To Convert To Solid , select the Background Object to be converted by left-
clicking the object or using a window selection method.

 

Before or after object selection, a Name can be assigned in the Properties tab.
Additionally, a Color and Reflectance can be chosen (see Using the Color Dialog)
just as would be the case when using the Individual Construction methods.

 

Right-click the mouse or press Enter to end the command and make the conversion.
The new Solid Object(s) will reside on the same Layer as the original
Background Object(s).

 

Grouped Background Objects can be converted in bulk. All converted objects will
be assigned the same Name, Color, and Reflectance as chosen in the
Properties tab. Individual Solid Objects will be created and will not be made a
Group.

 

It should be clear that only closed planar polygons can be converted to Solid
Objects. Visual will validate the selection by effectively ignoring the object selection if
it cannot be converted.

It is routinely the case that objects appear to be a closed polygon. If they are closed,
they will be converted. If they are not converted, they are simply not closed regardless
of the appearance. The user must apply Trim and Extend to provide a single vertex for
Visual to use.

 

 See Convert To Background for the opposite functionality.
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6.5 Copy
The Copy command applies to all object types and is used to create single or multiple copies of all selected objects.

The Copy command can be found on the Modify tab and the Home tab of the
Ribbonbar.

 

To Copy objects, left-click the object(s) you want to Copy with the selection box or use
a selection window to select a set of objects. Right-click to complete the selection
process of base objects.

See Selecting Objects for information on object selection methods.

 

Specify a Base Point with the mouse, keyboard, or Object Snap.  

After selection of a Base Point, movement of the mouse crosshairs within the
Design Environment will display a  graphical representation of the selected objects
as they are being translated to aid in the proper selection of a Destination Point.

 

Select a Destination Point with the mouse, keyboard, or Object Snap. Select
additional Destination Points for each additional Copy you want to create. At right,
note that the base object is highlighted in red (the system Selection Color) and
newly created luminaires are shown in the Color assigned to them.

 

To complete the Copy command right-click the mouse or press Enter.  
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Copy can be used on Luminaires, Background Objects, Solid Objects, and Calculation Zones.
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6.6 Edit Text
Text placed in Visual (created natively or by Import) can be edited with the Text Editor.

The Edit Text command can be found on the Modify tab of the Ribbonbar.  

To Edit Text, left-click to select the Text to be edited.  

The Text Editor is immediately initiated. Unlike other Modify commands, the object
will not be highlighted in the Design Environment.

The selected Text is shown in the Text Editor and changes to Height, Alignment,
and Wrapping can be made just as when the Text was originally created.

The orientation of the Text cannot be modified after the Text Editor is closed. See
Rotate for information on changing the angle of the Text.

The Color of Text is modified with Properties based on Layer selection and object
parameters as was the case during Text creation.

 

Click Update to apply the changes and exit the Text Editor. Clicking Cancel
ignores changes and closes the dialog.
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6.7 Erase
The Erase command removes objects from the lighting model.

The Erase command can be found on the Modify tab and the Home tab of the
Ribbonbar.

 

To Erase one or more objects, select the objects by left-clicking or selecting multiple
objects with a window selection method.

 

Right-click or press Enter to end the command.  

Erase applies to all object types.
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6.8 Explode
The Explode command allows connected objects to be un-Grouped (for Solid Objects) or un-Joined (for Background Objects). Objects like Rooms, Structures, and Polygons are
pre-connected upon construction. It may be desirable to break this connection to Erase or otherwise modify one of the sub-objects.

The Explode command can be found on the Modify tab of the Ribbonbar.  

To Explode an object, select the object(s) to be Exploded by left-clicking or using a
window selection method.

 

Right-click to end object selection and Explode the objects. In most cases, the
explosion will not be immediately obvious. At right, note that a single surface of the
Solid Object Room and the long sides of a Background Rectangle can be
individually selected, whereas above, prior to the explosion, the entire Room and
Rectangle where selected with a single left-click on each.

 

The Background Objects: Polylines, Rectangles, and Polygons can be
Exploded.

 

The Solid Objects: Room, Structure, and Grouped objects can be Exploded.  

See Group and Join for methods of connecting objects.
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6.9 Extend
The Extend command increases the length of a Line or Polyline (not Arcs) to meet or touch the selected Base Object.

The Extend command can be found on the Modify tab of the Ribbonbar.  

To Extend one or more Base Objects, left-click or use a window selection method
to choose the Boundary Edges or object(s) to extend to. Right-click or press Enter
to end object selection. Two Boundary Edges are selected at right; a Solid Object
square and a Background Line.

 

Left-click each object to be Extended to the Boundary Edge(s). It is necessary to
left-click on the half of the object nearest the Boundary Edge.

After each click, Visual Extends the object.

 

Right-click or press Enter to end the command.  

Extend operates on objects based on the current view. i.e. an object at Z=0 can be
Extended to an object at Z+1 when viewed in the Plan View, even if the objects
don't mathematically intersect. This functionality can be an advantage when
constructing advanced geometries when used in N, S, E, or W views. At right, a line is
extended to a vertical Solid Object.

 

Important Note:

Extending in isometric views can yield unsatisfactory results if Boundary Edges
objects are not in the same plane as the Extended object. At top right, the Plan
View and South view of two objects are shown; a line and a square. The common
assumption is that the Line will be Extended to the center of the square when in an
isometric view. This is not the way the command functions. At bottom, the Line is
Extended in SW View, and when viewed in Plan View, the results are not likely
what was intended.
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Extend operates only on Background Objects. Arcs cannot be Extended. Solid Objects can be used as Boundary Edges.

 



6.10 Extrude
Extrude is a term that describes the process of "stretching" a linear or planar object linearly into a (in most cases) third dimension to create a 3-D Solid Object from it. See the Pull command
for a more graphical and WYSIWYG method of extruding.

Extrude is a powerful tool for modeling Solid Objects because extruded shapes are
commonly found in modern architecture. At right, some examples of extruded shapes
are shown. The original planar object is shaded and the arrows indicate the direction
of extrusion.

 

Any existing Solid Object may be Extruded. Select the Extrude command from
the Modify tab of the Ribbonbar. The Properties tab will appear allowing for entry
of command parameters.

 

An Extrusion Distance must be entered. The default direction of Extrusion is
perpendicular to the plane of the Solid Object, in the direction nearest the point of
view.

To extrude in the opposite direction, specify a negative Extrusion Distance.

 

When Directional Extrusion is chosen, the Command Line will prompt for the
base and destination points of a vector to establish the direction of Extrusion. In
terms of the graphics above and at right, the base would correspond to the tail of the
arrow and the destination would correspond to the head. The exact location of the
chosen base and destination points is irrelevant as they only serve to indicate a
direction. The base and destination points may be entered manually as well. For
example, a base point of (0,0,0) combined with a destination point of (1,0,1) would
result in the extrusion at right, which is in the X-Z plane at an angle of 45°.

 

The result of Extrusion is a single Solid Object having the same Reflectance
value (taken from the original planar object) on all surfaces. Should varying
Reflectance values need to be assigned, this can be accomplished by editing the
Reflectance values by using the Properties command. The Grouped Solid Object
can also be Exploded into its component Solids.

 

Extruding Background Objects follows a similar methodology as Solid
Objects. Select the object to be Extruded, specify the extrusion distance in the
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Properties tab, and right-click or press Enter to end the command.

Lines can be Extruded to make Rectangles.  

Note that the Extrusion process is the core of the behavior when executing the Room and Structure commands. Review Rooms and Structures before deciding to construct a Solid Object
and Extrude it; i.e. constructing a Room or Structure may be a quicker process.
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6.11 Fla,en
The Flatten command changes the Z-coordinate of selected Background Objects to zero. This is very useful when importing CAD files to use as reference for a design since various heights
of objects that are not germane to the project can exist.

The Flatten command can be found on the Modify tab of the Ribbonbar.  

To Flatten objects, select the desired objects by left-clicking or with a window
selection method. "All" is useful in this case; see Selecting Objects. Note the first
graphic at right is an elevation view of the X-Z plane.

 

Right-click or press Enter to end the command and the objects are changed to have Z
= 0. Note the first graphic at right is an elevation view of the X-Z plane and that all
objects now have a Z-coordinate of "0".

 

Flatten only operates on Background Objects.
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6.12 Group
The Group command allows Solid Objects to be connected. This can allow for collective editing of Properties, use of Modify commands, or in complex projects, a cleaner model.

The Group command can be found on the Modify tab of the Ribbonbar.  

To Group objects, select the desired objects by left-clicking or using a window
selection method.

 

Right-click the mouse or press Enter to end object selection and automatically
complete the command.

 

The Group command only applies to Solid Objects. See Join for the analog command for Background Objects.
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6.13 Join
The Join command allows Background Line and Polylines to be connected. This can allow for collective editing of Properties, use of Modify commands, or in complex projects, a cleaner
model.

The Join command can be found on the Modify tab of the Ribbonbar.  

To Join objects, select the desired objects by left-clicking or using a window selection
method.

 

Right-click the mouse or press Enter to end object selection and automatically
complete the command.

 

Lines or Polylines must touch and cannot cross at vertices. The level of Zoom
may indicate a viable vertex when one does not actually exist. The command will not
change the length of base objects; Extend and Trim must be used to "clean up" the
base objects.

 

Objects of different Color and Line Width will be made the Color and Line Width
of the object with the highest Polyline Number. The number of any Polyline can be
found with the Properties command. After Joining, the resultant Polyline can be
modified with Properties if desired.

 

The Join command only applies to Background Objects. See Group for the analog command for Solid Objects.
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6.14 Mirror
The Mirror command applies to all object types and is used to produce a Mirror image of selected items.

The Mirror command can be found on the Modify tab of the Ribbonbar.  

Select the objects to be Mirrored by left-clicking or with a window selection. Right-
click or press Enter to complete the selection process.

See Selecting Objects for information on object selection methods.

 

Mirroring occurs about a Mirror Line that must be user-specified. The mouse is
normally used for this, but keyboard and Object Snap input are also accepted. Left-
click to establish the first coordinate about which mirroring will occur.

In the example at right, it is known that the restrooms are symmetric and then the
midpoint of a line between walls can be used as the Base Point to mirror the
Luminaires, Solid Objects, and Calculation Zones.

 

As the mouse crosshairs are moved, an implied Mirror Line will be drawn from the
Base Point to the mouse cursor, and the Mirrored objects are temporarily shown to
assist in proper Mirror Line input.
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Specify the second point of the Mirror Line with the mouse, keyboard, or Object
Snap. Visual completes the command after the complete specification of the Mirror
Line.

Use of Orthogonal Mode is often an advantage since architecture is often parallel to
the Cartesian axes. Similarly, using the keyboard to specify "@1<90" also yields the
result at right.

 

Mirror can be used on Luminaires, Background Objects, Solid Objects, and Calculation Zones.
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6.15 Move
The Move command is used to uniformly translate selected objects in the Design Environment.

The Move command can be found on the Modify tab and the Home tab of the
Ribbonbar.

 

To Move one or more objects, Left-click on the object you want to Move with the
selection box or use a selection window to select a set of objects.

Right-click or press Enter to end object selection.

 

Select a Base Point with the mouse, keyboard, or Object Snap.  

After selection of a Base Point, movement of the mouse within the Design
Environment will display a graphical representation of the selected objects as they
are being translated to aid in the proper selection of a Destination Point.

 

Select a Destination Point with the mouse, keyboard, or Object Snap.

Visual automatically ends the command and Moves the object(s).

 

The Move command applies to all object types.
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6.16 Offset
The Offset command creates a Background Object similar to the base Background Object but applies non-linear scaling to change the shape accordingly.

The Offset command can be found on the Modify tab of the Ribbonbar.  

To Offset an object, select the base object by left-clicking with the mouse. Right-click
the mouse or press Enter to end object selection.

Offset operates on multiple objects but because results can be confusing, it is
recommended that Offsets be applied to one object at a time.

 

Select the Base Point with the mouse, keyboard, or Object Snap.

The Base Point can be positioned anywhere related to where the Offset is desired;
it does not have to be on the side of the object where the new object will be created.
The Base Point defines the first end of a direction vector that tells Visual how to
make the Offset.

 

The Offset Distance must be specified in the Properties tab of the Ribbonbar.

The Offset of the object is made parallel to the base object.

 

Moving the mouse after selection of the Base Point shows the implied Offset in red.
The direction of the offset is based on an imaginary line (shown in gray at right) drawn
parallel to the base object. This imaginary line is not drawn in Visual.

Moving to one side or the other of the imaginary line changes the directional vector and
causes Visual to move the Offset object from one side to the other of the base object.

 

Select the second point of the direction vector. Visual automatically ends the
command, creating the new object(s). The new Background Object is created with
the same properties as the base object; Color and Width are preserved. Properties
can be modified if necessary.
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For multi-segment Background Objects, the behavior of the direction vector is
often non-linear and complex as can be seen at right. It is recommended that the
implied drawing feature inherent to the command be used to determine if the Offset is
desirable and/or where the Offset object will be created.

Polylines may need to be Exploded and/or Joined prior to Offsetting to create the
desired result.

 

Offset only applies to Background objects.
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6.17 Pull
The Pull command is effectively the same as the Extrude command with the exception that the Extrusion/Pull distance is specified with the mouse, the keyboard or Object Snap. Pull only
operates on Solid Objects.

The Pull command is found on the Modify tab of the Ribbonbar.  

To use the Pull command, select the objects to be manipulated by left-clicking. Right-
click or press Enter to proceed.

 

Visual will automatically begin Pulling the object by attaching the farthest extent to the
mouse crosshairs. Note that Pulling only occurs perpendicular to the plane of the
Solid Object chosen, with the positive direction of Pull being in the direction of the
Surface Normal. Moving the mouse shows the implied Pulled shape.

 

Left-click the mouse to choose the desired distance. Note that keyboard input is valid
in that a distance can be input; to Pull 10 units, enter "10" at the command line. Input
of direction information via the "<angle" method is not valid.

 

Pull only applies to Background Objects and Solid Objects.

file:///C:/Users/Eric/AppData/Roaming/verychmzip/Chapter_6_Modify/6.10_Extrude.htm
javascript:TextPopup(this)
javascript:TextPopup(this)
javascript:TextPopup(this)


6.18 Rotate
The Rotate command imparts an angular displacement to objects parallel to one of the Cartesian planes. Rotation occurs only in the Active Plane.

The Rotate command can be found on the Modify tab and the Home tab of the
Ribbonbar.

 

To Rotate one or more objects, select the objects by left-clicking or selecting multiple
objects with a window selection method.

 

Select the Base Point for rotation with the mouse, keyboard, or Object Snap.
Right-click or press Enter to end object selection.

 

Movement of the mouse in the command shows the implied rotation of the selected
objects. 0° is the X-axis if rotated in the X-Y or X-Z planes and the Y-axis if rotated in
the Y-Z plane.

 

Specify the angle to Rotate with the mouse, keyboard, or Object Snap. The
command will be automatically completed after the angle is specified with a left-click.
Specification with the keyboard at the Command Line requires a right-click or
pressing Enter to end the command.

Using Orthogonal Mode and the mouse, 90° rotations can be ensured without
having to rationalize clockwise or counterclockwise when viewed in 3-D.
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To Rotate an object vertically, simply choose the desired Active Plane, and repeat
the steps above. Since rotation can only be applied parallel to a Cartesian plane, the
exact (X,Y,Z) location of the Active Plane is not important. At right, rotation occurs in
the Y-Z plane, or in other words, the rotation occurs about the X-axis.

 

As an additional example, the same 3-D arrow is rotated at right in the X-Z plane, or in
other words, the rotation occurs about the Y-axis.

 

Rotate applies to all object types.
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6.19 Scale
The Scale command changes the size of objects based on the application of one or more factors to the (X,Y,Z) coordinates.

The Scale command can be found on the Modify tab of the Ribbonbar.  

To Scale one or more objects, left-click or select objects with a window selection
method.

Right-click or press Enter to end object selection.

 

Select a Base Point with the mouse, keyboard, or Object Snap. See below for
detailed information and examples.

Selection of the Base Point automatically completes the command.

 

A Scale Factor must be specified in the Properties tab. The factor can be any decimal value and is applied as would be expected; e.g. a Scale Factor of 2 would make objects twice
their original size and 0.5 would result in half size.

The Uniform option (the default) for Scale Factor applies a single factor to the X, Y,
and Z dimensions.

For example, at right a 1x1x1 cube becomes 2x2x2.

 

The Non-Uniform option for Scale Factor applies a separate factor to each of the
X, Y, and Z dimensions as specified in the individual Properties tab fields.

For example, at right, a 1x1x1 cube becomes 4x3x2.

 

Selection of the Base Point may cause a translation of the source object(s) with an increase or decrease in size:
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 1. Selecting a Base Point at the corner of an object changes the size but doesn't
cause a translation (a movement in the X, Y, and/or Z-direction). For example, with a
Uniform Scale Factor of 0.5, a 2x2 square is reduced to a 1x1 square and the
lower-left corner (being the Base Point) remains in the same location.

 

2. Selecting a Base Point at (0,0,0) changes the size and translates the object by the
same factor(s). For example, with a Uniform Scale Factor of 2, a 1x1 square
located at (3,2,0) would be moved to (6,4,0) and would become 2x2 in dimension.

 

3. Non-Uniform Scaling of a Solid or Background Circle yields an ellipse. For
example, a 2x2 Circle with Scale Factors of 2, 1, and 1 respectively yields an ellipse
with a major axis of 4 and a minor axis of 2. The Base Point here is the center of the
Circle.

 

Mathematically, the equations applied when scaling are shown at right.  

The Scale command applies to Background Objects, Solid Objects, and Calculation Zones. Luminaires cannot be scaled but their location can be scaled if, for instance, a CAD
Import file was misjudged to be drawn in feet and it was really inches, a 1/12 Scale Factor could be applied to the entire lighting model to correct the error.
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6.20 Stretch
The Stretch command changes the size or shape of objects non-proportionally. Stretch will effectively move the selected objects and then alter the adjoining objects.

The Stretch command can be found on the Modify tab and the Home tab
of the Ribbonbar.

 

To Stretch an object, left-click the object(s). A selection should be made to
fully select the object(s) that will remain the same shape. The process could
be thought of as "stretching the connectors to keep the base objects
attached as they are moved."

 

Select a Base Point with the mouse, keyboard, or Object Snap. This is
the first end of a direction vector that will define the amount and direction of
Stretch. Normally, a selection would be made on the object with the
mouse. Once an object is selected, the vertices will be highlighted. Multiple
left-clicks will select multiple objects. Right-click the mouse or press Enter
to end object selection.

 

Moving the mouse in the command shows the implied change to the base
objects, so the result can be verified before ending the command.

 

Select the end of the direction vector (Destination Point) with the mouse,
keyboard, or Object Snap and the command is automatically completed.

 

If the initial object selection is made at a vertex, behavior changes slightly.
The vertex will be moved and the abutting edges will be changed to suit that
selection. Note that only one vertex is highlighted. (This is the same
methodology as before except the base object is a zero-length line.)

 

Two examples illustrating behavior and usefulness:
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1. Multiple edges are selected, the mouse is moved to two positions, and
the final selection is made. Note that the selected objects do not change.
The objects adjacent to the selected objects morph to make the new shape.

 

2. A change has been made to a small office to increase the size by one
foot in width and a new CAD file has been Imported. (This can be seen at
right in the Background objects that are uneditable.) The appropriate
edges are selected with a crossing window method; including the
Calculation Zone. Finally, the new design is ready to be calculated after
the changes have been applied.

 

The Stretch command applies to all objects except Luminaires.
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6.21 Trim
The Trim command decreases the length of any Background Object (Lines, Polylines, Circles, and Arcs) to meet the selected Base Object or Boundary Edge.

The Trim command can be found on the Modify tab of the Ribbonbar.  

To Trim one or more Base Objects, left-click or use a window selection method to
choose the Boundary Edges or object(s) to extend to. Right-click or press Enter to
end object selection.

 

Left-click each object to be Trimmed to the Boundary Edge(s). It is necessary to
left-click on the half of the object nearest the Boundary Edge. After each click,
Visual Trims the object. At right, the previous Line is shown dashed along with the
clicked location.

 

Right-click or press Enter to end the command.  

Trim can also remove the included portion of the Trimmed object. The segment
bounded by the Boundary Edges will be removed wherever it may be. At right, the
previous Line is shown dashed along with the clicked location.

 

Trim operates on objects based on the current view. i.e. an object at Z=0 can be
Trimmed to an object at Z+1 when viewed in the Plan View, even if the objects don't
mathematically intersect. This functionality can be an advantage when constructing
advanced geometries when used in N, S, E, or W views.
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Important Note:

Trimming in isometric views can yield unsatisfactory results if Boundary Edge
objects are not in the same plane as the Trimmed object. At top right, the Plan View
and South view of two objects are shown. The common assumption is that the Line
will be Trimmed to the center of the square. This is not the way the command
functions. At bottom, the Line is Trimmed in SW View, and when viewed in Plan
View, the results are not likely what was intended.

 

Trim operates only on Background Objects. Solid Objects can be used as Boundary Edges.
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